~ 1 min read

DokuWiki Upgrade Error

After recent upgrade to my DokuWiki installation (I jumped from Mulled Wine straight to the latest release - Anteater)

I was getting this weird error:

call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'Doku_Renderer_metadata::section_edit' was given

the solution was to disable all the plugins and re-enable them again. Not sure why it worked, but it worked and the error is gone now! So if you experience the same error - try this. If it doesn't help, another good idea could be gradually re-enable plugins and see which one is the offender. Good Luck!